YouCast no longer updating with new YouTube "version".

May 7, 2015 at 3:55 AM
Edited May 7, 2015 at 3:00 PM
YouTube's new "version" has finally affected YouCast it seems. User Name feeds stopped updating today, though it seems Playlist feeds still work, for now. Hope this can be fixed, or there's a whole lot of YouTube I won't be able to watch anymore. YouCast was a lifesaver, allowing me to see my local news and weather updates that I couldn't receive OTA or stream properly on our local DSL.

https://youtu.be/UKY3scPIMd8



Update: oops, didn't realize there was a version 2.0 of YouCast, seems to be working so far. My goof.

Update 2: Nope, false alarm. V 2.0 isn't updating either.
May 8, 2015 at 3:45 AM
It's working fine for me now. I think there might have been a temporary hiccup – my subscriptions didn't seem to be updating last night, but they are now, and when I updated this evening, it seems to have caught everything from both yesterday and today.
Coordinator
May 8, 2015 at 11:24 AM
YouTube ended support for their v2 API so I had to update YouCast to work with v3.
Older versions of YouCast may stop working now but the latest version should work fine (it does for me).

Are you still having issues?
May 9, 2015 at 3:42 PM
Yep, still having issues. I uninstalled both versions, then re-downloaded last night, and set up some feeds. The initial grab worked, and it pulled the latest 10 videos that were available. This morning though, those channels have each added several more videos already, but it's not pulling them down for me.
May 12, 2015 at 4:28 AM
By sheer happenstance, I've discovered that if after downloading the initial fetch, I can then close YouCast . . . and then restart it, it updates the feeds. So, I don't know if that's by design, since the last version was able to be left running in the tray continuously, but for me at least I have to shut it down and restart it to update. A slight annoyance, but at least I can get my local weather forecasts and news again and have them waiting on my when I get home, instead of waiting 20 minutes to buffer a 3 minute video. :)
May 25, 2015 at 6:35 AM
I too seem to have this issue. Mine hasn't updated anything since the 20th. It doesn't seem to be doing anything and isn't producing any errors. It is the most recent version of the software and nothing has changed on the system in that time.
Coordinator
Aug 24, 2015 at 12:30 PM
Hey,
Does that still happen? There could be a bug in the caching mechanism which is based on YouTube's Etag.
If so, could you please post the channel this happens on so I could test it locally?

Sorry for the overdue reply, I didn't get a chance to drill in to this issue.
-Bar Arnon
Aug 24, 2015 at 5:47 PM
Hi,

Yep, still happening. I've gotten into the routine of closing YouCast down nightly and then restarting it to fetch the new videos. It happens on every channel I subscribe to, but here's one that updates frequently with new content and is a good example:

https://www.youtube.com/user/wish

and for measure, here's another one:

https://www.youtube.com/user/wrtv6



No worries on the delay, this is still a fantastic app, and a godsend for us "country" folk. Thank you for developing it.
Aug 25, 2015 at 6:41 PM
Since the youtube change i cant make the app update my feeds whatever i do. Previously it worked fine but i have kind of assumed this project was abandoned and moved to an rss reader to watch them which is a terrible alternative.

I was finding that every 3 or 4 weeks the app would suddenly just dump a whole load of new episodes - everything since it last updated but then nothing thereafter until several weeks later again

I am happy to give things another go however, Can someone confirm the format of what i need to add?Is it user or channel now or should either still work?
Coordinator
Aug 28, 2015 at 7:34 PM
I've uploaded a new version (2.1).
The only new feature is audio feeds but there were many underlying changes beneath the covers.
I haven't had time to test it so it's a beta but I hope it solves any issues you've previously had.

https://youcast.codeplex.com/releases/view/617045
Marked as answer by I3arnon on 8/31/2015 at 12:06 AM
Aug 30, 2015 at 6:26 PM
Seems to be working. Very cool. Stupid DASH, gonna miss those 1080p videos. Oh well. :)

Thanks for this.
Coordinator
Aug 31, 2015 at 8:05 AM
Well, if that makes it better, evidently they were never 1080p to begin with.

Anyways, I'll close this discussion, but if you have bugs or suggestions feel free to open an issue here or on GitHub: https://github.com/i3arnon/YouCast
-Bar Arnon